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Preface
Many books on Excel are either limited and cover only the basic concepts in small 
steps or are exhaustive and explain in great detail all the possible options in the 
program. This book covers only those topics that are essential for professionals and 
for students in higher education. It is a practical book, intended for everyone who uses 
Excel extensively or wants to start using it for their work or studies. After reading this 
book, professionals already working with the program will be able to get more out of 
their models.

This book provides step-by-step explanations using concrete practical examples illus-
trated with screenshots. The example files are available at www.gettingmoreoutofex-
cel.nl so you can go through these step by step yourself. Full answers to the examples 
can also be found here. Relevant exercises are included for each topic so you can prac-
tice using the knowledge gained from the content. The answers to these exercises can 
also be found at www.gettingmoreoutofexcel.nl. After studying this book, you will 
have all the knowledge and tools needed to use Excel in a professional manner.

Getting More Out of Excel 2019 is suitable for both Windows and Mac users, using Excel 
version 2016 and more recent versions.  However, all screenshots come from Excel 2019 
(Windows), which may sometimes vary slightly from what Excel 2016 or Mac users see 
on their screen. Office 365 users always have access to the latest version of Excel. As a 
result, small differences can occur in that version as regular updates of Office 365 be-
come available. Any larger differences between the versions are explained in the text. 
Not all components of Excel are available when using a mobile version of Excel (tablet 
or smartphone).

No prior knowledge of Excel is needed to get started with this book, but you are ex-
pected to have basic skills used in apps like Microsoft Word, such as copying, pasting, 
selecting, opening and saving files, and using italics and boldface. With these skills 
you won’t have any problems with this book.

The expected results of all examples and exercises are given. The full answers of the 
examples and exercises are available at www.gettingmoreoutofexcel.nl.

Questions, comments, or requests for training courses based on the book are welcome. 
Please send these to ben.groenendijk@outlook.com.

February 2019 
Ben Groenendijk
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Chapter 1

Basics
This chapter covers basic Excel skills. Section 1.1 explains how to insert text, 
numbers, and a calculation in Excel. Next comes Section 1.2 on the different ways 
to insert a function, Section 1.3 on how to sort, and Section 1.4 on relative and 
absolute cell references. Section 1.5 looks at how to filter a collection of data and 
this chapter is concluded in Section 1.6 with how to quickly navigate around a 
worksheet.

Note
The files mentioned in this chapter and the following chapters can all be 
found at www.gettingmoreoutofexcel.nl.

1.1	 Text, numbers and calculations

Example 1.1

1.	 Open the file Examples 1.xlsx and select the worksheet Example 1.1. If it is not visible, 
click the bottom left arrows, next to the worksheet tabs. Worksheets in Excel con-
tain rows and columns. The intersection of a row and column is called a cell. Columns 
are identified with letters and rows with numbers, for example, column B and row 3. 
The intersection of those two is called cell B3. When you select a cell, the cell borders 
are shown in bold. This is called the cell pointer. After column Z, the Excel columns 
are lettered AA, AB, AC etc. There are three main actions you can perform in a cell: 
enter text, enter numbers and insert calculations.

2.	 Enter the text Description in cell A1, Quantity in cell B1, Unit price in cell C1 and 
Subtotal in cell D1 (see Figure 1.1). Note that the word Description is wider than the 
width of the column. Once you type Quantity in the next column, part of the word 
Description will be hidden. You can easily adjust the column width here by placing 
the mouse pointer between the column headings A and B (see Figure 1.1) and double 
clicking. Column A will then be resized to fit the text. You can also drag the mouse 
in this position to make the column wider.

	 Also note that by default all text is left aligned in an Excel cell.

Figure 1.1
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3.	 Enter some text in the cells below Description and a few quantities under Quantity 
(see Figure 1.2). Note here that numbers are right aligned in cells by default.

4.	Enter the numbers 7.25, 89.50 and 12.90 under Unit price (see Figure 1.2). Note that 
decimal points should be used in English and also that the final 0 is not shown in 
the numbers 89.50 and 12.90. Note that whether a decimal point or comma is used 
in numbers depends on a setting in Windows or macOS.

Figure 1.2

5.	Select the cells C2:C4 (format for the cells C2 to C4), and then go to Home > Number > 
Accounting Number Format (see Figure 1.3). Microsoft calls the tabs along the top 
“ribbons”, as known from other programs like Word. There are the Home, Insert, 
Page Layout, etc. ribbons, each of which contains various command buttons. These 
buttons are organized in logical groups, for example, the Home ribbon contains the 
Clipboard, Font, Alignment, Number, etc. groups. The Accounting Number Format button 
shows the selected numbers as currency, with the $ symbol and two decimal places. 
The Accounting Number Format button actually consists of two parts: a $ symbol and a 
small triangle directly to the right (arrow pointing down). You can click this icon to 
select other currencies (see Figure 1.4). Note that the default currency sign displayed 
depends on a setting in Windows or macOS.

Figure 1.3

Figure 1.4
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6.	Select cell D2. Say you want to insert a calculation in this cell. Any calculation that 
can be done on a calculator can also be inserted here. That could be addition, sub-
traction, multiplication, division, bracket use, square root calculation, or exponen-
tial calculation. However, you enter the calculation differently than on a calculator. 
To calculate the subtotal in cell D2, you would enter the following on a calculator:

	 12 x 7.25 =. In Excel, a calculation always starts with the = symbol. Excel knows this 
will be followed by a calculation, not text or a number. Also, you do not enter num-
bers, but you refer to the cells that contain the numbers.

	 In cell D2 enter =B2*C2 and press Enter to display the answer.
	 Select cell D2 again. The answer to the calculation will now be displayed in cell D2 

(see Figure 1.5). Cell D2 also displays a number (87.00), but this is a calculation. The 
calculation for this cell is displayed in the formula bar, =B2*C2 (see Figure 1.6). The 
multiplication symbol used here is * instead of the usual x.

Figure 1.5

Figure 1.6

7.	 Manually inserting formulas is time-consuming and error prone, especially with 
a formula such as =A123*D141. It is best to learn not to type in the cells, but to select 
the cells with the cursor keys or with a mouse or by touch if you are using a touch 
screen.

	 Remove the formula in cell D2 (with the Del key or by going to Home > Editing > Clear 
> Clear All). Type in the = symbol, then select cell B2 using the cursor keys, mouse or 
touch, then type in the * symbol and select cell C2 with the cursor keys or mouse. 
Then press Enter to display the answer. Naturally the result will be the same. Use 
this method to insert calculations from now on. It takes a little getting used to, but 
in time will become automatic.

	 This book is based on the use of a keyboard and mouse, but readers with a touch 
screen can use the equivalent touch commands.

8.	You could repeat this process for the other two rows, but here is the great thing 
about Excel. Select cell D2. The cell border will be displayed in bold, which is called 
the cell pointer. There is a small square in the lower-right corner, the fill handle (see 
Figure 1.7). If you hover the mouse over the square, your mouse pointer will change 
to a black + sign and you can drag the cell (including the formula) down into the 
next two rows. The formulas for the other two cells will automatically be adjusted. 
You can use these quick and simple steps to calculate a number of rows with just one 
single formula. This way it does not matter whether you need to create three of the 
same calculations, as in the example, or three hundred!
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Figure 1.7

9.	Type the text Total in cell C6 and the calculation =D2+D3+D4 in cell D6, which will 
calculate the total amount (599.00). This is one way to insert the calculation, but a 
better method is to: press =, select cell D2, press +, select cell D3, press +, select D4 
and press Enter.

10.	 Change the number for Hammer to 14. This will immediately adjust the subtotal 
and total amount.

11.	 Make sure the headers Description up to Subtotal are in bold.

Excel has a number of unconventional characters for calculations, for example, you use 
the * sign for multiplication instead of the x sign that you see on your calculator (see 
Figure 1.8).

Editing Excel symbol Example
Addition + =A13+C15
Subtraction - =A13-C15
Multiplication * =A13*C15
Division / =A13/C15
Exponentiation ^ =A13^3
Square root calculation ^0.5 =A13^0.5

Figure 1.8

Another example is given here for more practice with inserting a formula in Excel.

Example 1.2

What would the future value be if you deposited capital in the bank for a number of 
years at a fixed interest rate? This would involve compound interest (interest on inter-
est). The formula for this is:

FV = PV * (1 + i) n

where:
FV: future value
PV: the present value of the investment
i: interest rate earned each period
n: number of periods capital is invested.
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1.	 Open the file Examples 1.xlsx and select the worksheet Example 1.2.
2.	 Select cell B7 and the following formula: =B4*(1+B5)^B6. Enter this with cell refer-

ence, so first type in the = symbol, point to cell B4, then type *(1+, select B5), type ^), 
select B6 and then finally press Enter. Note that if nothing happens when you type 
in the ^ symbol, you can press the space bar. The answer is: 1410.59876.

3.	 Select cell B7, click the Home ribbon, go to the Number group and click the currency 
button (Accounting Number Format).

4.	Enter a number of values for capital (PV), interest and investment term to automati-
cally calculate a new future value.

Exercise 1.1
1.	 Open the file Exercises 1.xlsx and select the worksheet Exercise 1.1. If it is not visible, 

click the bottom left arrows, next to the worksheet tabs.
2.	 Make the columns wider so the column headers are fully readable.
3.	 Make sure the Rent/Month column is displaying dollars.
4.	Calculate the subtotal for cell D2 (uses (number/month) x rent/month) and auto-

matically copy that formula to the three other rows by using the fill handle.
5.	Make sure the total of the four rows is shown in cell D7.
6.	The column headers Container type through to Subtotal should be in bold.

Exercise 1.2
1.	 Open the file Exercises 1.xlsx and select the worksheet Exercise 1.2.
2.	 In inventory management, the total cost for holding stock can be calculated with the 

following formula: Total cost = D /Q* CO + (Q / 2 + SS) *Cs. D: annual demand,  
Q: order quantity, CO: ordering cost, SS: safety stock, Cs: stock costs per unit. 
Calculate the total cost in cell B8. The answer is: $32,062,500.00. You will initially 
see ###########, because column B is not wide enough to display the whole 
amount. So you need to widen column B (see Figure 1.1).

1.2	 Inserting functions

Excel has many different functions. This section looks at a number of these functions 
and how to use them. Many other functions will be discussed in the following chap-
ters.

The example in the previous section calculated the sum of a few numbers. The method 
used there is time-consuming if you have more than three numbers. Another option is 
to use the =SUM() function, which allows you to sum up a series of numbers.
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Example 1.3

1.	 Open the file Examples 1.xlsx and select the worksheet Example 1.3.
2.	 Select cell H2 and then type =SUM(, and then select cells A2:G2 , and press Enter. 

This will calculate the sum of the numbers in the range A2 to G2 (254).
3.	 Select cell H2 again. The formula bar now contains the function =SUM(A2:G2). Note 

that you do not need to add the closing bracket – Excel automatically does this for 
you. A function always has a name and two brackets (...). You specify what the func-
tion does between the brackets. The SUM() function calculates the sum of a range of 
cells. That range of cells is called the function argument. In this example that is to 
sum up the numbers in cells A2 to G2 (addition).

4.	Also calculate the sum of the numbers for the other three rows by using the inserted 
function and dragging the fill handle (see Figure 1.7).

5.	Type the text Total in cell G7. Select cell H7 and calculate the sum of all cells, 
=SUM(A2:G5). Answer: 1706. We see here that the argument can be a row or column, 
but can also be a block of numbers (array). You can also sum up the cells H2:H5 for 
the same result of course.

Tip
This example shows only four rows of numbers, which makes it easy to 
drag the formula with the fill handle. However, with 300 rows of num-
bers that’s a lot of dragging. Another solution is to double click the fill 
handle, which copies the formula to all underlying rows (and then no 
dragging is needed). Delete the formulas in cell H3:H5. Select cell H2, and 
then double click the fill handle. This immediately inserts the formulas 
into cells H3:H5.

Excel has many more functions. A number of the formulas are listed below:
= AVERAGE()	 This formula calculates the average of a range of numbers.
=MAX()	� Gives the largest value in a range of cells. Works with both numbers 

and text (alphabetic) or dates.
=MIN()	 The same as MAX(), but gives the smallest value in a range of cells.
=SQRT()	 Calculates the square root of a number. Can also be calculated with 

^0.5 (see Figure 1.8).

Example 1.4

1.	 Open the file Examples 1.xlsx and select the worksheet Example 1.4.
2.	 You want to calculate the students’ grade point averages. Select cell F2. Select the 

Home ribbon, go to the Editing group and click the arrow next to the summation 
symbol (∑AutoSum) for the drop-down menu (see Figure 1.9). This menu lists a 
number of commonly used functions. Select Average. The function will suggest a 
series of numbers, C2:E2. The suggestion is correct, so you can press Enter for the 
answer. (Answer: 5.) If the suggested series of numbers is incorrect, you need to se-
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lect the correct series before you press Enter. Note that this is an alternative method 
for inserting a function. You can also insert the function yourself by inserting the 
= symbol and then the first letters of the word average. Excel will give you a list box 
with possible functions, and then you can double click AVERAGE. You still need to 
select the series of numbers.

Figure 1.9

3.	 Select cell F2. The cell shows the value 5, but the formula bar shows the 
AVERAGE(C2:E2). Use the fill handle to calculate the grade point averages of the other 
students (see the tip given with example 1.3).

4.	The grade point averages are displayed in a number of different ways. The first four 
without decimal places and the last two with lots of decimal places. There is a simple 
solution here. Select the cells F2:F7, and then go to Home > Number > Decrease Decimal 
(see Figure 1.10). The numbers will now be shown with only one decimal place (you 
will need to click several times). You can use the icon next to the Decrease Decimal 
icon if you want to show more decimal places .

Figure 1.10



8

Getting More Out of Excel

Figure 1.11

5.	Type Lowest grade in cell G1 and adjust the width of the column to fit. Then select 
cell G2 and click the Min function (see Figure 1.9). Note that the suggested series 
of numbers is incorrect, and needs to be selected again, =MIN(C2:E2). The student’s 
lowest grade will now be displayed. Also calculate the lowest grade for the other 
students, using the fill handle.

6.	Create another column, and call this one Highest grade and calculate the highest 
grade for each student.

7.	 Make sure all numbers are shown with one decimal place. Select the cells C2:H7 and 
click Increase Decimal (see Figure 1.10).

8.	The student numbers actually start with a zero, so Dennis’s student number is 0987. 
However, if you enter that number, the zero will disappear (called trimming). Try 
it to see what happens. Excel determines the data type (text, number, date, etc.) by 
default. Since a number never starts with a zero, the zero is automatically removed. 
The data type for Student no. is Number. Since the student numbers are not used to 
make calculations, the data type needs to be changed to Text. Select the cells A2:A7,  
go to the Home ribbon, then Number group and then click the list box (see Figure 1.11). 
Choose the option Text from the list box.

Note
You can also change the data type by selecting the cells and then 
right-clicking and selecting Format Cells. This list box gives many more 
options you can select for cell formatting.
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9.	The student numbers are automatically aligned to the left. Now you can manually 
add 0 in front of each student number. Select the cell and insert the 0 in the formula 
bar in front of the number.

Note
1.	 After entering the 0 in front of the student numbers, a small green 

triangle will appear in the top left corner of the cells. This is a small 
warning symbol. Excel is warning you here that there is a possible 
error in the cell. The cell values in our example are correct, so you can 
ignore this warning. If you want to remove these warnings, select 
the cells concerned, A2:A7, then click the exclamation mark that will 
appear alongside the selected cells (see Figure 1.12). The possible error, 
Number Stored as Text, will be displayed. The numbers in our example 
are correct, so select Ignore Error.

	 Those green warning symbols will appear again if any changes are 
made, so they can be annoying. You can permanently disable them by 
going to File > Options > Formulas and unselecting Enable Background 
Error Checking.

2.	 You can also add the leading zero automatically. See Examples 1.8 and 
Exercise 1.9 if you want to know how this works.

Figure 1.12

Exercise 1.3
1.	 Open the file Exercises 1.xlsx and select the worksheet Exercise 1.3.
2.	 Calculate the average grades for each course in cells C9:E9.
3.	 Calculate the highest grades for each course in cells C10:E10.
4.	Calculate the lowest grades for each course in cells C11:E11.
5.	Calculate the average grade for all three courses in cell C12. (Answer: 5.83.)
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6.	Calculate the average grade for the courses Economics and Project in cell C13. 
(Answer: 6.00.)

Tip
Select the function = AVERAGE() in the usual way. Now first select the 
cell range C2:C7, then hold down the Ctrl (Mac: Cmd) key to select 
multiple items, and then select E2:E7. The formula bar will now contain 
= AVERAGE(C2:C7,E2:E7). Note that the punctuation between the series 
depends on a setting in Windows or macOS. A comma is used here, but 
another common punctuation mark is the semi-colon (;).

7.	 The individual grades should be displayed with one decimal place.
8.	All average grades should be displayed with two decimal places accuracy.

1.3	 Sorting

A feature frequently used in Excel is the data sorting feature. This section discusses 
this sorting function.

Example 1.5

1.	 Open the file Examples 1.xlsx and select the worksheet Example 1.5.
2.	 Say you want to sort the grade data according to grade point average. First select the 

whole area that needs to be sorted, including the column headers. This is the cell 
range A1:H7. We want to sort by grade point average, but all the other data gets sorted 
too!

3.	 Once you have selected the whole cell range A1:H7, select the Home ribbon, go to the 
Editing group, click Sort & Filter and select Custom Sort (always choose this option for 
sorting).

4.	A Sort help window appears where you can specify which column(s) you would like 
to sort within the selected area (see Figure 1.13).

5.	 In the first column, select Sort by and choose the column Grade point average. In the 
second column, select Cell Values, as you want to sort by number values and not, for 
example, by cell color. In the last column, select Smallest to Largest to sort in ascend-
ing order.

Note
The My data has headers box in the upper right corner of the sort window 
is selected. This is correct, because the data has been selected together 
with the column texts (headers). This is why the column headers are in-
cluded in the selection range. If you did not include the column headers 
in the selection, then you need to clear the check box.
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Figure 1.13

6.	Click OK in the sort window. The data will now be sorted; the student Linda with a 
grade point average of 4.7 is now listed first.

7.	 It is possible to enter another sorting order. There are now three sixes listed in 
random order under the grade point average. When you have equal values for grade 
point averages, it is best to sort again by student number. Again, select the whole 
area that needs to be sorted, cells A1:H7, including the column headers.

8.	Click Sort & Filter and select Custom Sort again.
9.	Click Add Level in the sort window. Select Student no. from the Then by drop-down 

list (see Figure 1.14). Leave the second column on Cell Values and the third column 
on A to Z. The student numbers are text fields, which is why the third column gives 
the order A to Z.

10.	 Click OK again. Another warning symbol will appear because you have formatted 
numbers as text. We are aware of this, so you can click OK. The data will be sorted 
again with the new sorting condition. See how equal final grades are now sorted by 
student number.

Figure 1.14
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Note
If you need to sort by say Grade point average, then select all data that 
needs to be sorted, including the column headers. This way you know 
for certain which area is being sorted. Do not just select the Grade point 
average column! That can really mess up the data, and a student with a 4.7 
may end up with a 7 and vice versa. Excel does warn you that the selected 
area may be too small, but this approach is still very error prone.

Exercise 1.4
1.	 Open the file Exercises 1.xlsx and select the worksheet Exercise 1.4.
2.	 Sort the data by Highest final grade (smallest to largest).
3.	 If there are equal highest grades, you can sort by student name (from A to Z).
4.	After sorting, the warning symbol will appear again for the student numbers. 

Disable the warning message so it no longer shows.

1.4	 Relative and absolute cell references

Sections 1.1 and 1.2 showed a useful method for inserting formulas and functions and 
then dragging them into other rows and columns by using the fill handle. These cell 
references are automatically adjusted by Excel. This is called relative cell referencing. 
However, this is not always convenient, if you want to keep referencing the same cell 
when you drag the calculation to the other rows or columns. This is called absolute 
referencing. The example below shows how this is done.

Example 1.6

1.	 Open the file Examples 1.xlsx and select the worksheet Example 1.6.
	 Here the sales of an item from weeks 1 to 5 are displayed, including the total sales for 

all five weeks. We want the Percentage column to show which percentage a particular 
week contributed to the total. Select cell C2 and insert the calculation:  
=B2/B8. (Answer: 0.11627907.)

2.	 The answer is 11.6%, but is not displayed as such. Select cell C2 and in the Home 
ribbon go to the Number group and click Percent Style. Show the percentage with one 
decimal place (Home > Number > Increase Decimal). Always have Excel show per-
centages as decimals and make sure they are displayed as percentages. This way you 
do not have to divide or multiply by 100 in calculations with percentages.

3.	 Select cell C2 and drag the calculation into the other weeks using the fill handle. 
This will cause the error notification #DIV/0! (see Figure 1.15). Excel is warning that 
you have tried to divide a number (value) by zero. This has happened because you 
dragged the formula down. Each time you drag the formula, Excel moves the formu-
la down one cell.

	 So if you drag the formula down to cell C3, the formula for cell C3 will look like this: 
=B3/B9.
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	 You are then no longer dividing by the total (B8), but by the cell below (B9). This is 
called relative copying. Relative copying is used most, but has gone wrong in this 
example.

	 To prevent this you need to fix the cell with the total (make it absolute) and make 
sure the cell does not change during the copying process. This way you move cell B2 
one step down (relative) each time, but the total (B8) remains fixed (absolute) and 
the formula remains correct. Each week’s sales is then divided by cell B8.

	 If this generates strange results when dragging a formula (see Figure 1.15), this will 
usually mean one or more cells have not been made absolute.

Figure 1.15

4.	Select cell C2 again. Cell B8 needs to be made absolute in the formula bar (see 
Figure 1.16). Click cell B8 in the formula bar and then press the F4 key (depending 
on the keyboard, this key can be selected either directly or in combination with 
the Fn key; Mac users can also use Cmd-T). Cell B8 is placed between $ signs (see 
Figure 1.16). Cell B8 has now been made absolute and is displayed as $B$8. When it is 
copied using the fill handle, it will always remain cell B8.

Figure 1.16

5.	Now calculate the percentage of total sales for the other weeks again. It now works 
correctly. Go to cell C4, for example, and check whether this cell divides by cell B8.

Tip
When referencing a cell that needs to be made absolute, press the F4 key 
(Mac: Cmd-T or Fn-F4). The $ signs will immediately be inserted in the 
cell reference. As you can see, the F4 function key is used a lot in Excel. 
Note again that using the F4 key depends on the keyboard. You can either 
use it directly or in combination with the Fn key (Fn+F4). Mac users can 
also use Cmd-T.



14

Getting More Out of Excel

Exercise 1.5
1.	 Open the file Exercises 1.xlsx and select the worksheet Exercise 1.5.
2.	 A container repair company charges $60.00 per hour of labor. The sales tax on the 

labor is 6%. The labor costs are to be listed in the Labor column. Calculate the labor 
costs in cell F7 (excl. sales tax) using cell B4 (Answer: $90.00).

3.	 Copy cell F7 into the cells for other repairs using the fill handle. If you get an error 
notification, you will know where the error is (see Section 1.4). If this happens, cor-
rect it.

4.	Calculate the sales tax for the labor costs in cell G7 using cell B3 (Answer: $5.40).
5.	Copy cell G7 to the other repairs.
6.	Calculate the total (labor costs + sales tax = $95.40) in cell H7 and copy this to the 

other repairs.

1.5	 Filtering

Adding one or more filters in Excel allows you to select part of the rows from the 
worksheet. Filters are used so you can display a limited section of the rows from the 
worksheet. The example below shows how this is done.

Example 1.7

1.	 Open the file Examples 1.xlsx and select the worksheet Example 1.7.
	 A small supermarket chain has three branches. The turnover is registered for each 

item group at each branch for a number of days.
2.	 Click column heading A to select the entire A column (branch). In the Home ribbon, 

go to Editing > Sort & Filter > Filter.
3.	 The first cell in column A, cell A1, now contains a visible list box button (see 

Figure 1.17). If you select the list box, an AutoFilter will be displayed. Clear the Select 
All box and check the Tampa box. Note that Blanks is also in the list. There are also 
blanks in the selected column. Excel will now filter on Tampa, and only show the 
Tampa branches. Note that the list box icon has now changed to a filter symbol. This 
indicates that a filter has been applied to the column.

4.	Select the list box in cell A1 again. Check the Select All box. Then click column head-
ing C to select the entire C column (Item group). Again, go to the Home ribbon and 
select Edit > Sort & Filter > Filter. The filter for column A has now been removed. Next, 
click Filter again to activate a filter in column C.

5.	 In column C, filter on Miscellaneous and Meat products (clear Select All box and then 
check two boxes).

6.	Remove the filter in column C and create a filter in column B (Date). In the list box, 
you can filter by year, month or day. There are many more filter options for dates; 
select Date Filters to see the long list of filter options (see Figure 1.18).
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Figure 1.17

Figure 1.18
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7.	 In Date Filters, select After, then enter the date 6/5/2019 in the is after box. All rows 
with a later date will be shown. You can also check the boxes here, but our example 
shows how to use the data filters option.

8.	Remove the filter in column B and create a filter in column D. There is not much use 
filtering on one of the numbers here. In Number Filters, select Top 10. Display the top 
5 items. The top 5 (highest) turnovers will now be displayed.

9.	Change the filter to display the lowest 5 turnovers. Select Top 10 again and change 
Top to Bottom.

10.	 Change the filter to 10% of the highest turnovers. Select Top 10 again and change 
Bottom to Top and Items to Percent.

11.	 Remove the filter in column D. There are no active filters now and no selected col-
umns. Now select a random cell in one of the four columns. Again, go to the Home 
ribbon > Edit > Sort & Filter > Filter. All columns (A-D) will now contain a filter icon.

12.	 Once a column has a filter icon, it is often not as easy to read the header. The 
column needs to be made slightly wider, but this can also be done automatically. 
Select the columns A to D. Go to the Home ribbon > Cells > Format > AutoFit Column 
Width. The header should of course be aligned to the left.

13.	 Filter on Naples only. Leave the filter on and also filter on Bakery. The turnover for 
all bakeries in Naples will now be shown. As an example, create another filter, to 
show only bakery turnovers in Naples that are higher than $13,000.00. Use the 
Number Filters option.

14.	Remove all filters. Go to the Home ribbon > Editing > Sort & Filter > Filter.
15.	 Enter the text Sum in cell C63 and the sum for the turnover in D63. (Answer: 

$1,047,970.88.)
16.	 Filter now on Miami branches and on Blanks (if Blanks is not visible, then you have 

not selected the entire column A before selecting the filter. Of course it’s not nec-
essary to select it). If you do not filter out Blanks the SUM() function will no longer 
be visible. Try this to see how it works. The sum in cell D63 will remain the same! 
So you will not get to see the sum for all branches in Miami. The same goes for the 
MIN(), MAX(), and AVERAGE() functions. This is possible with a different function.

17.	 Show all branches, remove the filter by checking Select All in the AutoFilter menu 
or selecting Clear Filter From Branch. Also type the word Sum in cell C64. In cell 
D64, insert the multi-functional SUBTOTAL() function. It is multi-function-
al because this function can be used for calculating things like the minimum, 
maximum, sums and averages. The first argument is the Function_num that 
calculates things like the minimum, maximum, sum and average. The second 
argument is the range. In cell D64 type =SUBTOTAL( and a help window will 
appear (see Figure 1.19). Select 9 - SUM. Next type a , (comma) and select the range 
that you want to add, D2:D61. End with a ) (closing bracket). Cell D64 now contains 
=SUBTOTAL(9,D2:D61). (Answer: $1,047,970.88.) Note that the punctuation between 
the arguments depends on a setting in Windows or macOS. A comma is used here, 
but another common punctuation mark is the semi-colon (;).

18.	 Filter on Miami branches and on Blanks (if Blanks is in the list). The result of cell 
D64 is now $382,539.70. If you do not filter on Blanks, the two functions will no 
longer be visible. Try this to see how it works.
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Figure 1.19

Note
V	 Depending on the data type in the column, Text Filters, Number Filters 

or Date Filters are shown in the AutoFilter menu.
V	 You can also select Filter in the Data ribbon > Sort & Filter > Filter.
V	 A magnifying glass (the search symbol) is shown to the right of the 

ribbon with the text Tell me what you want to do. Type in Filter here, or 
the first letters, and you can also quickly add or remove a filter. 

V	 You can add filters to a range of columns, for example, select column A 
and column B and then add the filter. What you unfortunately cannot 
do is select column A and column C and then add the filter.

V	 You do not necessarily have to filter a whole column as you can also 
filter part of a column.

V	 In the SUBTOTAL() function, for example, the minimum can be deter-
mined with the number 5, maximum with the number 4 and average 
with the number 1 (see Figure 1.19).

V	 The black borders in this example were added by going to Home > Font 
> Border > All Borders.

Exercise 1.6
1.	 Open the file Exercises 1.xlsx and select the worksheet Exercise 1.6.
2.	 Filter column B for the work day Tuesday.
3.	 Remove the filter in column B. Now filter all prices (unit price) equal to greater than 

$100.00. Use Number Filters.
4.	Remove the filter. Now filter on all subtotals above the average subtotal.
5.	Remove the filter. Now filter on the second quarter (via All dates in the Period).
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6.	Remove the filter. Now add a filter in all columns and make sure all the column 
headers are readable.

7.	 In cell F52 calculate the smallest quantity ordered and in cell F53 the largest quanti-
ty ordered. When you filter, both of the filter functions need to work. (Answers for a 
filter on the East region: 6 and 90.) Remember to filter on empty cells.

8.	Disable, but do not remove, the filter. In cell H52 calculate the total amount and in 
cell H53 the average subtotal. When you filter, both of the filter functions need to 
work. (Answers for a filter on the East region: 4599.31 and 242.07.) Remember to 
filter on empty cells.

1.6	 Navigating

A useful feature of Excel is the use of shortcut keys for navigating and selecting. These 
allow you to quickly and easily navigate through the worksheet or make selections.
This is especially useful with large worksheets containing a lot of data. If you have 
300 rows, for example, and you have to select cell A1 to A300, you need to scroll all 
the way to the bottom. This is easier with a few shortcut keys. There are actually only 
two keys you need to remember: the Ctrl key and the Shift key. All the other keys are 
quite self-explanatory. The most important shortcut keys for navigating are shown in 
Figure 1.20.

Shortcut key Action
Ctrl+Home (Mac: Ctrl+Fn+←) Moves the cell pointer to the first cell in the worksheet (A1).
Ctrl+End (Mac: Ctrl+Fn+→) Takes you to the last cell containing a value, the bottom right corner of the 

worksheet.
Ctrl+↑ (Mac: Cmd+↑) Selects the uppermost cell in a column.
Ctrl+↓ (Mac: Cmd+↓) Selects the last cell containing a value in a column.
Ctrl+← (Mac: Cmd+←) Selects the first cell in a row.
Ctrl+→ (Mac: Cmd+→) Selects the last cell containing a value in a row.

Figure 1.20

You use the same keys as in Figure 1.20 to select cells, only now you also need to hold 
down the Shift key. If you want to select the entire worksheet, for example, first press 
Ctrl+Home, selecting cell A1, and then press Ctrl+Shift+End. The cell pointer will go to 
the last cell containing a value and will select the entire area.

Exercise 1.7
1.	 Open the file Exercises 1.xlsx and select the worksheet Exercise 1.7.
2.	 Select the last cell containing a value using a shortcut key.
3.	 Manually select cell G20 and move the cell pointer to G1 using the shortcut keys.
4.	Move the cell pointer to the last cell containing a value in column G using the short-

cut keys.
5.	Manually select cell G20 and select cell G1:G20 using the shortcut keys.



19

Chapter 1 – Basics

6.	Now practice some more basic skills from this chapter. Make sure the annual sales 
of the items appear in column O with the column header Annual sales.

7.	 Then sort the annual sales figures in descending order, so from largest to smallest 
value. The figure 7709 now appears in the first row.

8.	In column P, determine the percentage of the annual sales of the item with respect 
to the total annual sales (first determine this - answer: 35704). Use %Annual sales 
as the column header. Make sure the figures are shown as a percentage with two 
decimal places. The first item displayed has the percentage 21.59%.

9.	In column Q, column header Cum.sales , determine the cumulative annual sales 
(for the first item the annual sales of that item, for the second item the annual sales 
of the first and second item, for the third item the annual sales of the first, second 
and third item, etc.). The first item is 7709; the second is 11817.

Tip
For example, the cumulative sales of the fifth item is the same as the 
cumulative sales of the fourth item + the sales of the fifth item.

10.	 In column R, determine the percentage (to two decimal places) of the cumulative 
annual sales of the item with respect to the total annual sales. Use %Cum.sales as the 
column header. The first item is 21.59% and the second item is 33.10%.

11.	 Make sure the column headers are fully readable. Delete (ignore) the green trian-
gles in column O and Q (see note under Example 1.4).

In this exercise, a partial ABC analysis is made of the sales data. A items are fast mov-
ers, B items are normal items and C items are slow movers. Column R clearly shows 
how much the items contribute to the sales.

Exercise 1.8
1.	 Open the file Exercises 1.xlsx and select the worksheet Exercise 1.8.
2.	 Practice the steps of Exercise 1.7 again, but now based on the turnover. Redo exercis-

es 1.7.6 to 1.7.11, but replace sales with turnover.
3.	 If you see ######### in a column, the column is too narrow for the number.  

In that case, make the column wider (see Figure 1.1).

The following example and exercise are only for Excel enthusiasts!

Example 1.8

In Example 1.4, student numbers of the type Text were made and then an 0 was typed 
manually in front of the student number. This is feasible if you have just a few stu-
dents, but if you have to do this for thousands of students, it becomes very laborious. 
You can solve this by “pasting” two or more pieces of text to each other.
1.	 Open the file Examples 1.xlsx and select the worksheet Example 1.8.
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2.	 Column A should become data type Text. Select A2:A7 and in the Home ribbon > 
Number group, open the list box and select Text (this can also be done by right- 
clicking > Format Cells).

3.	 Different pieces of text can be put together using the & symbol. Select cell F2 and 
enter: =”o”&A2. Note here that the zero is set off by quotation marks, not two apos-
trophes in a row. Literal text must always be set off by quotation marks. Cell F2 now 
shows 0987 and can now be copied to the other students using the fill handle.

4.	F2 now contains a “calculation” and not literally 0987. So you cannot delete the 
student numbers from column A and move those from column F. However, you can 
convert the calculation into values. Select F2:F7, right-click and select Copy.

5.	Select cell F2, and right-click, and select at Paste Options the second option Values. The 
cells now contain values instead of calculations.

Note
V	 If after entering the calculation in cell F2 you see =”0”&A2 instead of 

the answer 0987, the cell formatting has accidentally been changed. 
Select cell F2 and go to the Home ribbon > Editing > Clear > Clear all. 
Enter the calculation =”0”&A2 in cell F2 again.

V	 See also Section 8.2 Formatting with Flash Fill for another option to 
add an extra zero to a number.

Exercise 1.9
1.	 Open the file Exercises 1.xlsx and select the worksheet Exercise 1.9.
2.	 Column C should contain the email addresses of staff members. The company’s 

name is testmail.com. The email address consists of the initials, surname and 
@ testmail.com. So the first staff member gets the email address:  
M.Garcia@testmail.com.

3.	 Change the email address calculation to a normal email address using Paste options.

Note
Email addresses do not contain spaces. If the surname contains a prefix as 
in del Pilar, the email address will go wrong. Of course this can be solved 
in Excel. The spaces in a text can be cleared using the =SUBSTITUTE() func-
tion. This function allows you to substitute a piece of text for another 
piece of text. In our example the space needs to be substituted by nothing 
(no text). The function then appears as =SUBSTITUTE(B8,” “,””). If the text 
in cell B8 is del Pilar, then this function would change it to delPilar. Note 
that the second argument is a quotation mark, a space and then another 
quotation mark. The third argument is two quotation marks directly 
after each other with nothing in between. Here a space is replaced with 
nothing. To do this an extra column needs to be made containing the 
names without spaces. The email address is then compiled using this 
column.
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